Оформление
Сводка кодов ошибок
1. Обзор
1.1 Версия
| Версия сервера FineBI | Функциональные изменения |
|---|---|
| 6.0 | - |
1.2 Сценарии применения
В этой статье приведены распространенные коды ошибок FineBI, чтобы вы могли быстро найти ошибку и найти решение.
1.3 Описание кода
В процессе использования FineBI вы будете сталкиваться с различными ошибками, в это время вы можете проверить системный журнал FineBI %FineBI%/logs/fanruan.log, чтобы найти причину ошибки и решить проблему.
Коды ошибок обозначаются 8-значным кодом, как показано ниже:

Значение каждого бита кода ошибки следующее:
| Количество кодовых битов | Объяснение значения цифр |
|---|---|
| Позиция 1: Модуль делегата | 1: Заявления2: Платформы3: Возможность подключения данных6: BI |
| Бит 2: представляет тип журнала | 1: Журнал ошибок2: Журнал реплик |
| 3-я позиция: представляет собой неправильное расположение | 1: Неподдерживаемые функции2: Неправильное использование3: Аномальная информация4: Системные советы |
| Биты 4-8: представляют коды ошибок | Первые 3 цифры используются для классификации ошибки, следующие цифры используются для кодирования каждой ошибки.Дно 31: паук2: Установка и развертывание3: Функциональное использование4: Обновление данных |
2. неподдерживаемые функции
| код ошибки | журнал ошибок | Рецепт |
|---|---|---|
| 61100001 | Нет исключения для паучьих движков | **Анализ причин:**Функциональный пункт "BI-Distributed Engine" не был приобретен при регистрации проекта. Эта ошибка указывает на то, что функция необходима.**Решение:**Чтобы понять сценарий использования и влияние этой функциональной точки, обратитесь сначала к разделу "Управление регистрацией ".Если вы убедитесь, что вам нужна эта функция, обратитесь в отдел продаж для приобретения дополнительного устройства. |
| 61100002 | Необычное количество узлов, активных в движке-пауке | **Анализ причин:**Фактическое количество распределенных узлов spider, необходимых для проекта, больше, чем "количество распределенных узлов spider", приобретенное при регистрации.**Решение:**Супервайзер посетил сайт http://IP:端口/webroot/decision/v10/register/info/license, чтобы узнать предельные значения на момент регистрации.Если количество распределенных узлов достигнет предельного значения, новые узлы не будут добавляться, а добавленные узлы не будут отображаться.Если вы убедитесь, что вам необходимо добавить новый узел, обратитесь в отдел продаж для приобретения дополнительного оборудования. |
| 61100003 | Никаких аномалий в виде лицензий на добычу данных | Эта ошибка устарела. |
| 61100004 | Отсутствие функции BI-графика лицензия исключение | **Анализ причин:**Функциональная точка "BI-Chart" не была приобретена при регистрации проекта. Эта ошибка указывает на то, что функция необходима.**Решение:**Чтобы понять сценарий использования и влияние этой функциональной точки, обратитесь сначала к разделу "Управление регистрацией ".Если вы убедитесь, что вам нужна эта функция, обратитесь в отдел продаж для приобретения дополнительного устройства. |
| 61100005 | Отсутствие функции диаграммы лицензия исключение | **Анализ причин:**Функциональная точка "Статическая диаграмма" не была приобретена при регистрации проекта. Эта ошибка указывает на то, что функция необходима.**Решение:**Чтобы понять сценарий использования и влияние этой функциональной точки, обратитесь сначала к разделу "Управление регистрацией ".Если вы убедитесь, что вам нужна эта функция, обратитесь в отдел продаж для приобретения дополнительного устройства. |
| 61100006 | Исключение для лицензий на мобильные устройства | **Анализ причин:**Соответствующая функциональная точка не была приобретена при регистрации проекта. Эта ошибка указывает на то, что функция необходима.**Решение:**Мобильные устройства делятся на приложения, HTML5-версию, HTML5-интеграцию (WeChat, Nail, интеграция приложений сторонних производителей) для доступа к единому каталогу шаблонов/отчетов.В зависимости от сценария использования необходимо регистрировать различные функциональные точки, поэтому сначала ознакомьтесь с разделом "Управление регистрацией ", чтобы понять, какие функциональные точки требуются для данного сценария использования.Если вы убедитесь, что вам нужна эта функция, обратитесь в отдел продаж для приобретения дополнительного устройства. |
3. Ошибки в использовании
| код ошибки | журнал ошибок | Рецепт |
|---|---|---|
| 61200401 | Ошибки при обновлении из-за проблем с базой данных | **Анализ причин:Это ошибка обновления из-за проблемы, связанной с базой данныхРешение:**В журнале ошибок обновления найдите соответствующую таблицу данных и найдите соединение данных, соответствующее таблице данных.В разделе "Область поддержки подключения данных " найдите руководящий документ по подключению данных соответствующего типа и проверьте подключение данных и конфигурацию базы данных. |
4. аномальная информация
4.1 Двигатель-паук
| код ошибки | журнал ошибок | Рецепт |
|---|---|---|
| 61300101 | Не удалось получить доступ к имени хоста | **Анализ причин:Доступ к имени хоста невозможен, выбрасывается java.net.UnknownHostExceptionРешение:**Настройте имя хоста кластера пауков |
| 61300102 | Невозможно использовать порт XXXX | **Анализ причин:Ошибка конфигурации IP-портаРешение:**Изменение занятого порта: Изменение номера порта проекта FineBI |
| 61300104 | sprider Недостаточно места для хранения файлов на нескольких узлах | Недостаточно места в HDFSРасширение хранилища HDFS |
| 61300105 | паук Недостаточное количество памяти на нескольких узлах | Недостаточно места в AlluxioРасширенное пространство для Alluxio |
| 61300106 | паук Исключение при запуске многоузлового задания с памятью | Alluxio Worker зависает или переполнен (могут быть и другие причины).Обнаружение служб Alluxio |
| 61300107 | Не включена служба shuffle.service или недостаточно места в compute engine tmp | 1) Служба spark.shuffle.service не включена2) Недостаточно места на пути tmp в SparkДобавьте параметры в BI или измените соответствующую конфигурацию tmp-каталога Spark |
| 61300108 | Spider_calculation_engineblock Сбой записи | Рабочий Alluxio зависает или дублирует id временного блока.Проверка служб Alluxio, проверка идентификаторов блоков |
| 61300109 | Исключение для многоузлового файла данных узла | hdfs datanode зависаетПроверка службы HDFS |
| 61300110 | Сбой инициализации вычислительного механизма | Не удалось запустить искру1) Параметр spark_driver_host может быть неправильно настроен, и IP не соответствует действительности.(2) localhost в файле hosts соответствует более чем одному IP (автономная версия), в то время как кластерная версия может иметь более одного IP, настроенного с одним и тем же именем хоста на localhost, или hostanme соответствует неправильному IP.3) Исключение из службы Spark. Проверьте состояние веб-страницы Spark. (Должен быть узел со статусом ALIVE)4) Проверьте наличие других факторов, способствующих возникновению неисправности |
| 61300111 | Недостаточное распределение памяти BI | Недостаточный объем памяти на стороне BIИзменение памяти BI |
| 61300112 | Недостаточно места в каталоге временных файлов вычислительной машины | Увеличение дискового пространства в каталоге временных файлов Spark |
4.2 Функциональное использование
| код ошибки | журнал ошибок | Рецепт |
|---|---|---|
| 61300301 | Исключение типа файла | Обновление несоответствия типа файла ExcelПроверка обновленных типов файлов |
| 61300302 | Длина имени поля или таблицы превышает предел длины значения ключа и не может быть сохранена в конфигурации | Длина имени поля или таблицы превышает ограничение xxx и не может быть сохраненаИзмените название поля или таблицы на более короткое |
| 61300303 | Пустое сообщение об ошибкеУстранение неисправностей Отчеты об ошибках | |
| 61300304 | xx бизнес-пакет, xx таблица, xxx дубликаты имен полей | xx бизнес-пакет, xx таблица, xxx дубликаты имен полейИзмените имя поля так, чтобы оно не дублировалось |
4.3 Обновление данных
| код ошибки | журнал ошибок | Рецепт |
|---|---|---|
| 61300400 | Не удалось установить соединение с базой данных xx (и базой данных xx), проверьте соединение с данными | Сбой подключения к базе данныхПроверка соединений с базой данных |
| 61300401 | Недостаточно места на жестком диске | Недостаточно места на жестком дискеРасширение жесткого диска |
| 61300403 | Слишком много открытых файлов, превышающих установленное по умолчанию максимальное количество открытых файлов в системах Linux. | Linux: слишком много открытых файловНастройка количества открытых файлов для Linux |
| 61300404 | Поле xx таблицы xx (поле xx таблицы xx) пустое, и ассоциация не может быть успешно создана | Пустые поля создают ассоциацииПроверка межтабличных корреляций |
| 61300417 | Расчет набора данных Self-service превышает лимит объема данных [ячейки] и не может быть успешно рассчитан и обновлен. | Проанализируйте наборы данных для самоконтроля пользователей, которые не содержат ошибок медианного и деэквивалентного количества записей из-за превышения ограничений на объем данных в процессе вычислений или в процессе генерацииВ продукте есть тексты-подсказки. Основной эффект заключается в сокращении данных путем их агрегирования или добавления фильтров для завершения вычислений и генерации |
| 61300418 | Расчет медианных или дедуплицированных записей превысил предельный объем данных и не мог быть успешно рассчитан и обновлен | Анализ наборов данных самопомощи пользователей в связи с превышением ограничений по объему данных при расчете медианы или количества дедуплицированных записей |
| 61300419 | Количество рассчитываемых показателей превысило предел и не могло быть успешно рассчитано и обновлено | Слишком много показателей, участвующих в процессе расчетаСокращение количества индикаторов |
| 61300420 | Подсчет среднего/числового значения без выделения превышает ограничения по данным | Подсчет среднего/среднего значения на приборной панели превышает лимит данных1) Если вы используете таблицы базы данных, включите режим данных в реальном времени2) Используйте операцию "Summarise - De-Recount" в автономном наборе данных(3) Если использование параллелизма не слишком мало, попробуйте уменьшить порог расчета, расчет в пределах порога не будет сообщать об ошибках: "DistributedOptimizationConfig.spiderConfig.spider_distinct_median_threshold".Для версий проекта до 5.1.12 значение по умолчанию равно 100, что означает 1/100 памяти BI.В версии 5.1.12 и более поздних версиях проекта значение по умолчанию равно 25, что означает 1/25 памяти BI.4) Измените параметры базы данных конфигурации, после изменения всех параметров счетчик дедупликации будет работать медленнее, но не будет сообщать об ошибкахDistributedOptimizationConfig.spiderConfig.spider_distinct_use_spark_sql=true(5) Если корректировка по-прежнему сообщает об ошибке, это означает, что расчет очень большой, и рекомендуется добавить подробные условия фильтрации на приборную панель или использовать набор данных Self-service обработки данных для выполнения расчета. |
| 61300421 | Ваш набор данных самопомощи содержит более xxx ячеек данных и не может быть успешно обновлен, пожалуйста, сократите данные, которые необходимо обновить. Если вы сократили поля, продолжайте фильтровать данные или группировать их для обобщения | Неуместные действия пользователя не должны приводить к созданию очень большого количества данных, которые влияют на других пользователей или даже заполняют дисковое пространство.Сокращение объема генерируемых данных |
| 61300422 | Ваш набор данных самопомощи содержит более xxx строк данных и не может быть успешно обновлен, пожалуйста, сократите данные, которые необходимо обновить. Если вы сократили поля, продолжайте фильтровать данные или группировать их для обобщения | Сокращение объема генерируемых данных |
| 61300423 | Расчет набора данных Self-service превысил лимит объема данных [строка] и не смог быть успешно рассчитан и обновлен | |
| 61300424 | Расчет набора данных Self-service превысил лимит объема данных [память] и не смог быть успешно рассчитан и обновлен |
4.4 дашборд
| код ошибки | журнал ошибок | Рецепт |
|---|---|---|
| 61310001 | разрыв соединения | Ошибка конфигурации набора данных SQL - сбой соединенияИмя упаковки пустоеимя вкладки пустоеОператор SQL пустdataLinkName пустИсключение, вызывающее сбой при добавлении |
| 61310002 | Отсутствующие поля | |
| 61310003 | Поле используется | |
| 61310004 | Дублирование полей | |
| 61310005 | Поле не имеет разрешений | |
| 61310006 | Отсутствующие подгруппы | |
| 61310007 | Используется группировка | |
| 61310008 | группировка и повторение | |
| 61310009 | Группировка не имеет прав доступа | |
| 61310010 | Отсутствующие бизнес-пакеты | |
| 61310011 | Используются бизнес-пакеты | |
| 61310012 | Дублирование бизнес-пакетов | |
| 61310013 | Отсутствие разрешений на бизнес-пакеты | |
| 61310014 | клиническое испытание | |
| 61310015 | Таблица используется | |
| 61310016 | Повторение таблицы | |
| 61310017 | Таблица не имеет разрешений | |
| 61310018 | недостающее звено | |
| 61310019 | Ассоциации используются | |
| 61310020 | ассоциативное повторение | |
| 61310021 | Нет разрешения на объединение | |
| 61310022 | Типы таблиц не поддерживаются | |
| 61310023 | Услуги на уровне конфигурации не поддерживаются | |
| 61310024 | отклонение параметров | |
| 61310025 | дублирующее имя | |
| 61310026 | Неправильный путь | |
| 61310027 | недостающий путь | |
| 61310028 | Нет разрешения на работу с путями | |
| 61310029 | Недопустимая операция над таблицей | |
| 61310030 | недоступный путь | |
| 61310031 | Анализ отсутствия оперативной безопасности | |
| 61310032 | Дублирование шаблонов | |
| 61310032 | Сохранение исключений | |
| 61310033 | Шаблон не существует | |
| 61310033 | аномалия обновления | |
| 61310034 | Папка с шаблонами не существует | |
| 61310034 | Удалить исключение | |
| 61310035 | Запрос Исключение | |
| 61310036 | Тип компонента не поддерживается | |
| 61310037 | Исключение при обслуживании двигателя | |
| 61310039 | Ошибка получения имени сортировки | Ошибка конфигурации набора данных EXCELНесогласованные имена и порядок следования полей |
| 61310040 | ошибка запроса | Ошибка конфигурации набора данных EXCELНесоответствие количества и типа полей |
| 61310041 | Ошибка типа поля | Ошибка конфигурации набора данных EXCELТолько поддерживаемые форматы: xls, csv, xlsx |
| 61310042 | Ошибка страницы листа | Ошибка конфигурации набора данных EXCELПрочитайте только первый лист с данными, убедитесь, что из первой ячейки нет: сложных функций, программирования на VBA и т.д. |
| 61310043 | Ошибка заголовка листа | Ошибка конфигурации набора данных EXCELПервая строка - это имя поля, а вторая строка начинается со слова поля; убедитесь, что в первой строке нет слитых ячеек. |
| 61310044 | Ошибка круговой зависимости (вычисления) | |
| 61310045 | Шаблон редактируется | |
| 61310046 | Шаблон запущен | |
| 61310047 | Неправильный оператор SQL | Ошибка конфигурации набора данных SQL - неверный оператор SQLИмя упаковки пустоеимя вкладки пустоеОператор SQL пустdataLinkName пустИсключение, вызывающее сбой при добавлении |
| 61310048 | Сообщение о неопределенном исключении | |
| 61310049 | Идентификатор сеанса шаблона был закрыт исключением | |
| 61310050 | Имя шаблона пустое | |
| 61310051 | Публичные ссылки закрыты | |
| 61310052 | Акция закрыта | |
| 61310053 | Шаблонная сессия не найдена |
4.5 Связанные с функциями
| код ошибки | журнал ошибок | Рецепт |
|---|---|---|
| 61500001 | Синтаксическая ошибка в формуле | |
| 61500002 | Для неагрегированных формул существует подробная фильтрация | |
| 61500003 | Агрегатные и неагрегатные формулы для операций | |
| 61500004 | Использование агрегированных аргументов в агрегированных функциях | |
| 61500005 | Существует несколько показателей для функций агрегирования | |
| 61500006 | Только первая из функций быстрого вычисления может быть формулой | |
| 61500007 | Быстрое вычисление параметров в рамках функций без агрегатных функций |
5. системные оповещения
| Код журнала | Оповещения | Причины и решения |
|---|---|---|
| 62400000 | Функциональная точка получения данных запрос в норме | - |
| 62400001 | Произошла ошибка при получении данных компонента | Ошибка получения данныхSQL-оператор "SELECT xxxx" не выполняется, информация о полях не совпадает при добавлении таблицыПожалуйста, проверьте базу данных |
| 62400002 | Неполное получение данных о компоненте | Отсутствующие данные |
| 62400003 | Не имеют доступа к данным компонента | не имеет права |
| 62400004 | Компонент не имеет данных | Нет данных |
| 62400005 | Неполная конфигурация данных | Неполная конфигурация данных |
| 62400006 | Максимальное количество рядов не может превышать 100 Вт, пожалуйста, скорректируйте размерное поле или обратитесь к администратору | Компонент агрегации отображает больше данных, чем установлено пределом |
| 62400401 | Генерация xx таблиц в рамках xx бизнес-пакета не удалась, xx ассоциация (xxx ассоциация = имя кэша ассоциации) будет создана на основе исторических данных | Логика замены данных, сбой обновления для таблицы в таблице с существующими ассоциациямиПроверьте таблицу данных в соответствующем бизнес-пакете |
| 62400402 | Переход состояния в реальном времени таблицы анализа xx в бизнес-пакете xx, связанный с бизнес-пакетом xx, поскольку реальное время таблицы xx в бизнес-пакете xx было изменено | Если базовая таблица реального времени была изменена, при переходе в состояние (из извлеченного в реальное время) таблицы анализа выдается запрос на изменение состояния.Добавьте внешнее оповещение: таблица используется другими аналитическими таблицами, и изменение в реальном времени приведет к преобразованию связанной аналитической таблицы в реальном времени (необходимо разработать) |
| 62400403 | Текущая таблица была изменена, и данные необходимо обновить | Текущая конфигурация таблицы изменена, что приводит к необходимости обновить данные для таблицы, в которой рисуются числа |
| 62400404 | Исходная таблица была изменена, и данные необходимо обновить | Изменения конфигурации исходной таблицы, в результате которых таблицы с подтаблицами должны обновить свои данные |
| 62400405 | Поле xx таблицы данных xx в бизнес-пакете xx (и поле xx таблицы данных xx в бизнес-пакете xx) не соответствует соответствию "один-ко-многим" / "один-ко-многим" / "один-ко-многим", и ассоциация не может быть успешно создана. | Непостоянная принадлежностьПроверка межтабличных корреляций и доработка правок |
6. Экспорт журналов ошибок
При предварительном просмотре компонентов, обновлении таблиц данных, предварительном просмотре таблиц данных, редактировании таблиц данных, сохранении новых таблиц SQL, самостоятельном сохранении наборов данных, при возникновении отчетов об ошибках на внешнем интерфейсе поддерживается экспорт соответствующих системных журналов и файлов.
Нажмите "Подробная информация" отчета об ошибке, в первой строке появится кнопка "Экспорт журнала", нажмите "Экспорт журнала", чтобы экспортировать полную информацию об отчете об ошибке.

Распакуйте zip-файл журнала экспорта, чтобы включить в него следующее:

| газеты | элемент |
|---|---|
| error.txt | Конфигурация компонентов/конфигурация таблиц/конфигурация шаблонов для компонентов, сообщающих об ошибках, что облегчает поиск компонента, сообщившего об ошибке:* цель: имя таблицы/идентификатор компонента * комментарий: имя сопровождаемой таблицы / имя компонента |
| fanruan.gc.log | gc данные журнала с 00:00 дня до времени экспорта |
| fanruan.log | Данные журнала fanruan.log с 00:00 до момента экспорта. |
| инспекция.xlsx | Информация, связанная с окружающей средой |