Skip to content

Сводка кодов ошибок

1. Обзор

1.1 Версия

Версия сервера FineBIФункциональные изменения
6.0-

1.2 Сценарии применения

В этой статье приведены распространенные коды ошибок FineBI, чтобы вы могли быстро найти ошибку и найти решение.

1.3 Описание кода

В процессе использования FineBI вы будете сталкиваться с различными ошибками, в это время вы можете проверить системный журнал FineBI %FineBI%/logs/fanruan.log, чтобы найти причину ошибки и решить проблему.

Коды ошибок обозначаются 8-значным кодом, как показано ниже:

1583994792999877.png

Значение каждого бита кода ошибки следующее:

Количество кодовых битовОбъяснение значения цифр
Позиция 1: Модуль делегата1: Заявления2: Платформы3: Возможность подключения данных6: BI
Бит 2: представляет тип журнала1: Журнал ошибок2: Журнал реплик
3-я позиция: представляет собой неправильное расположение1: Неподдерживаемые функции2: Неправильное использование3: Аномальная информация4: Системные советы
Биты 4-8: представляют коды ошибокПервые 3 цифры используются для классификации ошибки, следующие цифры используются для кодирования каждой ошибки.Дно 31: паук2: Установка и развертывание3: Функциональное использование4: Обновление данных

2. неподдерживаемые функции

код ошибкижурнал ошибокРецепт
61100001Нет исключения для паучьих движков**Анализ причин:**Функциональный пункт "BI-Distributed Engine" не был приобретен при регистрации проекта. Эта ошибка указывает на то, что функция необходима.**Решение:**Чтобы понять сценарий использования и влияние этой функциональной точки, обратитесь сначала к разделу "Управление регистрацией ".Если вы убедитесь, что вам нужна эта функция, обратитесь в отдел продаж для приобретения дополнительного устройства.
61100002Необычное количество узлов, активных в движке-пауке**Анализ причин:**Фактическое количество распределенных узлов spider, необходимых для проекта, больше, чем "количество распределенных узлов spider", приобретенное при регистрации.**Решение:**Супервайзер посетил сайт http://IP:端口/webroot/decision/v10/register/info/license, чтобы узнать предельные значения на момент регистрации.Если количество распределенных узлов достигнет предельного значения, новые узлы не будут добавляться, а добавленные узлы не будут отображаться.Если вы убедитесь, что вам необходимо добавить новый узел, обратитесь в отдел продаж для приобретения дополнительного оборудования.
61100003Никаких аномалий в виде лицензий на добычу данныхЭта ошибка устарела.
61100004Отсутствие функции BI-графика лицензия исключение**Анализ причин:**Функциональная точка "BI-Chart" не была приобретена при регистрации проекта. Эта ошибка указывает на то, что функция необходима.**Решение:**Чтобы понять сценарий использования и влияние этой функциональной точки, обратитесь сначала к разделу "Управление регистрацией ".Если вы убедитесь, что вам нужна эта функция, обратитесь в отдел продаж для приобретения дополнительного устройства.
61100005Отсутствие функции диаграммы лицензия исключение**Анализ причин:**Функциональная точка "Статическая диаграмма" не была приобретена при регистрации проекта. Эта ошибка указывает на то, что функция необходима.**Решение:**Чтобы понять сценарий использования и влияние этой функциональной точки, обратитесь сначала к разделу "Управление регистрацией ".Если вы убедитесь, что вам нужна эта функция, обратитесь в отдел продаж для приобретения дополнительного устройства.
61100006Исключение для лицензий на мобильные устройства**Анализ причин:**Соответствующая функциональная точка не была приобретена при регистрации проекта. Эта ошибка указывает на то, что функция необходима.**Решение:**Мобильные устройства делятся на приложения, HTML5-версию, HTML5-интеграцию (WeChat, Nail, интеграция приложений сторонних производителей) для доступа к единому каталогу шаблонов/отчетов.В зависимости от сценария использования необходимо регистрировать различные функциональные точки, поэтому сначала ознакомьтесь с разделом "Управление регистрацией ", чтобы понять, какие функциональные точки требуются для данного сценария использования.Если вы убедитесь, что вам нужна эта функция, обратитесь в отдел продаж для приобретения дополнительного устройства.

3. Ошибки в использовании

код ошибкижурнал ошибокРецепт
61200401Ошибки при обновлении из-за проблем с базой данных**Анализ причин:Это ошибка обновления из-за проблемы, связанной с базой данныхРешение:**В журнале ошибок обновления найдите соответствующую таблицу данных и найдите соединение данных, соответствующее таблице данных.В разделе "Область поддержки подключения данных " найдите руководящий документ по подключению данных соответствующего типа и проверьте подключение данных и конфигурацию базы данных.

4. аномальная информация

4.1 Двигатель-паук

код ошибкижурнал ошибокРецепт
61300101Не удалось получить доступ к имени хоста**Анализ причин:Доступ к имени хоста невозможен, выбрасывается java.net.UnknownHostExceptionРешение:**Настройте имя хоста кластера пауков
61300102Невозможно использовать порт XXXX**Анализ причин:Ошибка конфигурации IP-портаРешение:**Изменение занятого порта: Изменение номера порта проекта FineBI
61300104sprider Недостаточно места для хранения файлов на нескольких узлахНедостаточно места в HDFSРасширение хранилища HDFS
61300105паук Недостаточное количество памяти на нескольких узлахНедостаточно места в AlluxioРасширенное пространство для Alluxio
61300106паук Исключение при запуске многоузлового задания с памятьюAlluxio Worker зависает или переполнен (могут быть и другие причины).Обнаружение служб Alluxio
61300107Не включена служба shuffle.service или недостаточно места в compute engine tmp1) Служба spark.shuffle.service не включена2) Недостаточно места на пути tmp в SparkДобавьте параметры в BI или измените соответствующую конфигурацию tmp-каталога Spark
61300108Spider_calculation_engineblock Сбой записиРабочий Alluxio зависает или дублирует id временного блока.Проверка служб Alluxio, проверка идентификаторов блоков
61300109Исключение для многоузлового файла данных узлаhdfs datanode зависаетПроверка службы HDFS
61300110Сбой инициализации вычислительного механизмаНе удалось запустить искру1) Параметр spark_driver_host может быть неправильно настроен, и IP не соответствует действительности.(2) localhost в файле hosts соответствует более чем одному IP (автономная версия), в то время как кластерная версия может иметь более одного IP, настроенного с одним и тем же именем хоста на localhost, или hostanme соответствует неправильному IP.3) Исключение из службы Spark. Проверьте состояние веб-страницы Spark. (Должен быть узел со статусом ALIVE)4) Проверьте наличие других факторов, способствующих возникновению неисправности
61300111Недостаточное распределение памяти BIНедостаточный объем памяти на стороне BIИзменение памяти BI
61300112Недостаточно места в каталоге временных файлов вычислительной машиныУвеличение дискового пространства в каталоге временных файлов Spark

4.2 Функциональное использование

код ошибкижурнал ошибокРецепт
61300301Исключение типа файлаОбновление несоответствия типа файла ExcelПроверка обновленных типов файлов
61300302Длина имени поля или таблицы превышает предел длины значения ключа и не может быть сохранена в конфигурацииДлина имени поля или таблицы превышает ограничение xxx и не может быть сохраненаИзмените название поля или таблицы на более короткое
61300303Пустое сообщение об ошибкеУстранение неисправностей Отчеты об ошибках
61300304xx бизнес-пакет, xx таблица, xxx дубликаты имен полейxx бизнес-пакет, xx таблица, xxx дубликаты имен полейИзмените имя поля так, чтобы оно не дублировалось

4.3 Обновление данных

код ошибкижурнал ошибокРецепт
61300400Не удалось установить соединение с базой данных xx (и базой данных xx), проверьте соединение с даннымиСбой подключения к базе данныхПроверка соединений с базой данных
61300401Недостаточно места на жестком дискеНедостаточно места на жестком дискеРасширение жесткого диска
61300403Слишком много открытых файлов, превышающих установленное по умолчанию максимальное количество открытых файлов в системах Linux.Linux: слишком много открытых файловНастройка количества открытых файлов для Linux
61300404Поле xx таблицы xx (поле xx таблицы xx) пустое, и ассоциация не может быть успешно созданаПустые поля создают ассоциацииПроверка межтабличных корреляций
61300417Расчет набора данных Self-service превышает лимит объема данных [ячейки] и не может быть успешно рассчитан и обновлен.Проанализируйте наборы данных для самоконтроля пользователей, которые не содержат ошибок медианного и деэквивалентного количества записей из-за превышения ограничений на объем данных в процессе вычислений или в процессе генерацииВ продукте есть тексты-подсказки. Основной эффект заключается в сокращении данных путем их агрегирования или добавления фильтров для завершения вычислений и генерации
61300418Расчет медианных или дедуплицированных записей превысил предельный объем данных и не мог быть успешно рассчитан и обновленАнализ наборов данных самопомощи пользователей в связи с превышением ограничений по объему данных при расчете медианы или количества дедуплицированных записей
61300419Количество рассчитываемых показателей превысило предел и не могло быть успешно рассчитано и обновленоСлишком много показателей, участвующих в процессе расчетаСокращение количества индикаторов
61300420Подсчет среднего/числового значения без выделения превышает ограничения по даннымПодсчет среднего/среднего значения на приборной панели превышает лимит данных1) Если вы используете таблицы базы данных, включите режим данных в реальном времени2) Используйте операцию "Summarise - De-Recount" в автономном наборе данных(3) Если использование параллелизма не слишком мало, попробуйте уменьшить порог расчета, расчет в пределах порога не будет сообщать об ошибках: "DistributedOptimizationConfig.spiderConfig.spider_distinct_median_threshold".Для версий проекта до 5.1.12 значение по умолчанию равно 100, что означает 1/100 памяти BI.В версии 5.1.12 и более поздних версиях проекта значение по умолчанию равно 25, что означает 1/25 памяти BI.4) Измените параметры базы данных конфигурации, после изменения всех параметров счетчик дедупликации будет работать медленнее, но не будет сообщать об ошибкахDistributedOptimizationConfig.spiderConfig.spider_distinct_use_spark_sql=true(5) Если корректировка по-прежнему сообщает об ошибке, это означает, что расчет очень большой, и рекомендуется добавить подробные условия фильтрации на приборную панель или использовать набор данных Self-service обработки данных для выполнения расчета.
61300421Ваш набор данных самопомощи содержит более xxx ячеек данных и не может быть успешно обновлен, пожалуйста, сократите данные, которые необходимо обновить. Если вы сократили поля, продолжайте фильтровать данные или группировать их для обобщенияНеуместные действия пользователя не должны приводить к созданию очень большого количества данных, которые влияют на других пользователей или даже заполняют дисковое пространство.Сокращение объема генерируемых данных
61300422Ваш набор данных самопомощи содержит более xxx строк данных и не может быть успешно обновлен, пожалуйста, сократите данные, которые необходимо обновить. Если вы сократили поля, продолжайте фильтровать данные или группировать их для обобщенияСокращение объема генерируемых данных
61300423Расчет набора данных Self-service превысил лимит объема данных [строка] и не смог быть успешно рассчитан и обновлен
61300424Расчет набора данных Self-service превысил лимит объема данных [память] и не смог быть успешно рассчитан и обновлен

4.4 дашборд

код ошибкижурнал ошибокРецепт
61310001разрыв соединенияОшибка конфигурации набора данных SQL - сбой соединенияИмя упаковки пустоеимя вкладки пустоеОператор SQL пустdataLinkName пустИсключение, вызывающее сбой при добавлении
61310002Отсутствующие поля
61310003Поле используется
61310004Дублирование полей
61310005Поле не имеет разрешений
61310006Отсутствующие подгруппы
61310007Используется группировка
61310008группировка и повторение
61310009Группировка не имеет прав доступа
61310010Отсутствующие бизнес-пакеты
61310011Используются бизнес-пакеты
61310012Дублирование бизнес-пакетов
61310013Отсутствие разрешений на бизнес-пакеты
61310014клиническое испытание
61310015Таблица используется
61310016Повторение таблицы
61310017Таблица не имеет разрешений
61310018недостающее звено
61310019Ассоциации используются
61310020ассоциативное повторение
61310021Нет разрешения на объединение
61310022Типы таблиц не поддерживаются
61310023Услуги на уровне конфигурации не поддерживаются
61310024отклонение параметров
61310025дублирующее имя
61310026Неправильный путь
61310027недостающий путь
61310028Нет разрешения на работу с путями
61310029Недопустимая операция над таблицей
61310030недоступный путь
61310031Анализ отсутствия оперативной безопасности
61310032Дублирование шаблонов
61310032Сохранение исключений
61310033Шаблон не существует
61310033аномалия обновления
61310034Папка с шаблонами не существует
61310034Удалить исключение
61310035Запрос Исключение
61310036Тип компонента не поддерживается
61310037Исключение при обслуживании двигателя
61310039Ошибка получения имени сортировкиОшибка конфигурации набора данных EXCELНесогласованные имена и порядок следования полей
61310040ошибка запросаОшибка конфигурации набора данных EXCELНесоответствие количества и типа полей
61310041Ошибка типа поляОшибка конфигурации набора данных EXCELТолько поддерживаемые форматы: xls, csv, xlsx
61310042Ошибка страницы листаОшибка конфигурации набора данных EXCELПрочитайте только первый лист с данными, убедитесь, что из первой ячейки нет: сложных функций, программирования на VBA и т.д.
61310043Ошибка заголовка листаОшибка конфигурации набора данных EXCELПервая строка - это имя поля, а вторая строка начинается со слова поля; убедитесь, что в первой строке нет слитых ячеек.
61310044Ошибка круговой зависимости (вычисления)
61310045Шаблон редактируется
61310046Шаблон запущен
61310047Неправильный оператор SQLОшибка конфигурации набора данных SQL - неверный оператор SQLИмя упаковки пустоеимя вкладки пустоеОператор SQL пустdataLinkName пустИсключение, вызывающее сбой при добавлении
61310048Сообщение о неопределенном исключении
61310049Идентификатор сеанса шаблона был закрыт исключением
61310050Имя шаблона пустое
61310051Публичные ссылки закрыты
61310052Акция закрыта
61310053Шаблонная сессия не найдена

4.5 Связанные с функциями

код ошибкижурнал ошибокРецепт
61500001Синтаксическая ошибка в формуле
61500002Для неагрегированных формул существует подробная фильтрация
61500003Агрегатные и неагрегатные формулы для операций
61500004Использование агрегированных аргументов в агрегированных функциях
61500005Существует несколько показателей для функций агрегирования
61500006Только первая из функций быстрого вычисления может быть формулой
61500007Быстрое вычисление параметров в рамках функций без агрегатных функций

5. системные оповещения

Код журналаОповещенияПричины и решения
62400000Функциональная точка получения данных запрос в норме-
62400001Произошла ошибка при получении данных компонентаОшибка получения данныхSQL-оператор "SELECT xxxx" не выполняется, информация о полях не совпадает при добавлении таблицыПожалуйста, проверьте базу данных
62400002Неполное получение данных о компонентеОтсутствующие данные
62400003Не имеют доступа к данным компонентане имеет права
62400004Компонент не имеет данныхНет данных
62400005Неполная конфигурация данныхНеполная конфигурация данных
62400006Максимальное количество рядов не может превышать 100 Вт, пожалуйста, скорректируйте размерное поле или обратитесь к администраторуКомпонент агрегации отображает больше данных, чем установлено пределом
62400401Генерация xx таблиц в рамках xx бизнес-пакета не удалась, xx ассоциация (xxx ассоциация = имя кэша ассоциации) будет создана на основе исторических данныхЛогика замены данных, сбой обновления для таблицы в таблице с существующими ассоциациямиПроверьте таблицу данных в соответствующем бизнес-пакете
62400402Переход состояния в реальном времени таблицы анализа xx в бизнес-пакете xx, связанный с бизнес-пакетом xx, поскольку реальное время таблицы xx в бизнес-пакете xx было измененоЕсли базовая таблица реального времени была изменена, при переходе в состояние (из извлеченного в реальное время) таблицы анализа выдается запрос на изменение состояния.Добавьте внешнее оповещение: таблица используется другими аналитическими таблицами, и изменение в реальном времени приведет к преобразованию связанной аналитической таблицы в реальном времени (необходимо разработать)
62400403Текущая таблица была изменена, и данные необходимо обновитьТекущая конфигурация таблицы изменена, что приводит к необходимости обновить данные для таблицы, в которой рисуются числа
62400404Исходная таблица была изменена, и данные необходимо обновитьИзменения конфигурации исходной таблицы, в результате которых таблицы с подтаблицами должны обновить свои данные
62400405Поле xx таблицы данных xx в бизнес-пакете xx (и поле xx таблицы данных xx в бизнес-пакете xx) не соответствует соответствию "один-ко-многим" / "один-ко-многим" / "один-ко-многим", и ассоциация не может быть успешно создана.Непостоянная принадлежностьПроверка межтабличных корреляций и доработка правок

6. Экспорт журналов ошибок

При предварительном просмотре компонентов, обновлении таблиц данных, предварительном просмотре таблиц данных, редактировании таблиц данных, сохранении новых таблиц SQL, самостоятельном сохранении наборов данных, при возникновении отчетов об ошибках на внешнем интерфейсе поддерживается экспорт соответствующих системных журналов и файлов.

Нажмите "Подробная информация" отчета об ошибке, в первой строке появится кнопка "Экспорт журнала", нажмите "Экспорт журнала", чтобы экспортировать полную информацию об отчете об ошибке.

Распакуйте zip-файл журнала экспорта, чтобы включить в него следующее:

газетыэлемент
error.txtКонфигурация компонентов/конфигурация таблиц/конфигурация шаблонов для компонентов, сообщающих об ошибках, что облегчает поиск компонента, сообщившего об ошибке:* цель: имя таблицы/идентификатор компонента * комментарий: имя сопровождаемой таблицы / имя компонента
fanruan.gc.loggc данные журнала с 00:00 дня до времени экспорта
fanruan.logДанные журнала fanruan.log с 00:00 до момента экспорта.
инспекция.xlsxИнформация, связанная с окружающей средой