Оформление
Ошибка переопределения предварительного просмотра таблицы / дашборд продолжает загружаться
1. предварительный просмотр таблиц сообщает об ошибках и дольше обновляется/приборные панели не загружаются
Проблемные явления:
При использовании jdbc-драйвера, базовым уровнем которого является экосистема hadoop, в автономном развертывании FineBI (например, при настройке подключения к данным APACHE IMPALA, Hadoop Hive, SPARK, TRANSWARP INCEPTOR (Starring Ring), APACHE Phoenix, Hbase) происходит одно из следующих действий:
1, ранее установленное соединение mysql с данными не удалось, соответствующая таблица выдает ошибку предварительного просмотра, а время обновления становится длительным.
2. Возьмите таблицу DB или набор данных SQL в соответствующей базе данных, чтобы сделать приборную панель, которая всегда загружается при предварительном просмотре.
Определение проблемы:
Проверьте подробные журналы бэкэнда и найдите в них содержимое, связанное с ZKNameNode, как показано ниже:

Анализ причин:
FineBI встроенная hsql база данных FineDB таблица FINE_CONF_ENTITY под DistributedOptimisationConfig.spiderConfig.spider_namenode_mode поле под таблицей DistributedOptimizationConfig.spiderConfig.spider_namenode_mode значение value в автономном развертывании в режиме Master, в кластерном окружении в режиме zookeeper, поэтому класс ZKNameNode не будет вызван в случае автономного развертывания. Класс ZKNameNode не вызывается при автономном развертывании, поскольку в кластерной среде значение находится в режиме Master, а в кластерной среде - в режиме zookeeper. Приведенный выше журнал показывает, что режим именования - zookeeper, а режим zookeeper склонен конфликтовать с другими jar-пакетами подключения данных, связанными с hadoop, что приводит к невозможности его правильного использования.
Решение:
Просто подключитесь к FineDB и измените значение поля DistributedOptimisationConfig.spiderConfig.spider_namenode_mode в таблице FINE_CONF_ENTITY на режим Master.

3.2 Ошибки предварительного просмотра данных
3.2.1 Проблемные явления
На экране предварительного просмотра данных после добавления таблицы базы данных появляется сообщение об ошибке: отключена труба, как показано на следующем рисунке:

3.2.2 Анализ причин
Проблемы сетевого окружения.
3.2.3 Решения
При настройке подключения к данным необходимо выбрать "Проверить перед подключением" и заполнить проверочный оператор в "Проверочном запросе SQL", чтобы проверить, доступно ли подключение к данным. Проверочный SQL-запрос не обязательно должен включать таблицу в соответствующей базе данных, например, вы можете заполнить select 1, как показано на следующем рисунке:
