Оформление
Проблемы, связанные с развертыванием Tomcat
1. Обзор
В этой статье описаны проблемы и решения, возникающие при развертывании проектов на Tomcat.
2. Примеры
2.1 Окно CMD в Windows
(1) Окно CMD в системе Windows по умолчанию можно редактировать. Если вы нажмете мышью на окно, это приведет к блокировке всех потоков Java, что приведет к ложной смерти и простою Tomcat. В это время вам нужно нажать "Свойства" в интерфейсе Tomcat's CMD. Как показано на следующем рисунке:

2) Снимите флажки с двух опций редактирования, нажмите "OK", чтобы сохранить свойства, и перезапустите Tomcat. Как показано на следующем рисунке:

2.2 О страницах, отображающих HTTP-статус 404
Скопируйте файл tools.jar из каталога установленного JDK в каталоге lib в %Tomcat_home%/lib или %Tomcat_home%/webapps/webroot/WEB-INF/lib.
2.3 Недостаточный объем памяти
Описание проблемы
Ошибка пароля администратора конфигурации или пробел в куче Java.
Анализ причин
Указывает на то, что Tomcat не хватает памяти и вам необходимо изменить конфигурацию памяти Tomcat.
Рецепт
См. документацию по изменению памяти: Изменение памяти
2.4 Развертывание Tomcat для версии 7.0.100
Версия 7.0.100 Tomcat требует, чтобы web.xml был помещен в %Tomcat_HOME%\webapps\webroot\WEB-INF, иначе будет выдано сообщение об ошибке.
Файл см. в разделе: web.xml
Примечание: Эта ошибка Tomcat была исправлена в версии 7.0.103.
2.5 Ошибка фронтэнда при удалении ассоциации 1:1 400
Описание проблемы
Когда клиентский проект развернут на Tomcat, при редактировании и удалении двух ассоциаций 1:1 таблицы вся страница выдает ошибку 400.
Анализ причин
Более поздние версии Tomcat (начиная с 7.0.76) строго следуют спецификации RFC 3986 для разрешения доступа, что приводит к появлению сообщения 400 на внешнем интерфейсе при изменении ассоциаций.
Рецепт
1) Измените файл %Tomcat_HOME%/conf/server.xml и добавьте следующий код:
maxpostsize="209715200" maxHttpHeaderSize="16384" relaxedPathChars="[]|" relaxedQueryChars="[]|{}^
\`"<>" useBodyEncodingForURI="true" URIEncoding="UTF-8"Как показано на рисунке ниже:

2) Перезапустите проект.
2.6 Просмотр собственной версии Tomcat для BI
Если вы хотите проверить версию сервера Tomcat, поставляемого с FineBI, выполните следующие действия:
1) С помощью программы сжатия откройте файл catalina.jar в каталоге %Tomcat_HOME%/lib/.

2) Двойным щелчком откройте папку META-INF, как показано ниже:

3) Щелкните правой кнопкой мыши на файле MANIFEST.MF, чтобы найти информацию о версии Tomcat, как показано ниже:
