Оформление
FAQ по запуску FineBI - Помощь FineReport | Разработка отчетов | Использование отчетов | Учебные пособия
Часто задаваемые вопросы по запуску FineBI
1. Обзор
1.1 Версия
| Версия сервера FineBI |
|---|
| 6.0 |
1.1 Описание проблемы
В этой статье кратко описаны причины и способы решения проблем, связанных с неудачным запуском проекта FineBI.
2. Недостаточно свободного места на диске
2.1 Недостаточно места на дисках Windows/Linux
Описание проблемы:
Если FineBI не удалось запустить, откройте журнал fanruan.log в разделе %FineBI%/logs, там сообщается об ошибке в ключевом слове:
- java.io.IOException: нет места на устройстве
- Недостаточно места на диске
Анализ причин:
Каталог установки в ожидании, на диске недостаточно свободного места.
Решение:
1) Обратитесь в отдел эксплуатации и обслуживания, чтобы увеличить дисковое пространство на сервере.
2) Очистите диск
Используйте команду df -h, чтобы проверить текущий размер диска, занимаемого каждым разделом, как показано на следующем рисунке:

Используйте команду du -sh * для просмотра размера каждой папки в текущем каталоге, как показано ниже:

Просто очистите ненужные файлы.
2.2 Недостаточно памяти на компьютере Mac
Описание проблемы:
При запуске FineBI выводится уведомление "хост не найден".
Анализ причин:
При развертывании на персональном компьютере Mac по умолчанию выделяется 1,2 г памяти. Эта проблема возникает, если общая память компьютера слишком мала или если другие программы занимают большой объем памяти, в результате чего остается мало свободной памяти.
Решение:
1) Рекомендуется развернуть другой сервер и обновить конфигурацию оборудования.
2) Если вам необходимо продолжить запуск проекта на этом устройстве, рекомендуется при запуске FineBI закрыть другие бесполезные процессы, чтобы обеспечить достаточный объем свободной памяти.
3. Недостаточность прав
3.1 Запуск BI без прав администратора
В системах Windows рекомендуется запускать FineBI от имени администратора, как показано на следующем рисунке:

3.2 Недостаточные права доступа к файлам
Описание проблемы:
FineBI не удалось запустить, откройте журнал fanruan.log в разделе %FineBI%/logs, там сообщается об ошибке в ключевом слове:
- Отказ в разрешении
- База данных не инициализирована
Анализ причин:
Недостаточно прав пользователя для запуска проекта
Решение:
Проверьте права пользователя на чтение/запись, вы можете использовать команду chmod -R 777, чтобы настроить права для соответствующей папки.
3.3 Невозможность создания временного каталога
Описание проблемы:
FineBI не удалось запустить, откройте журнал fanruan.log в разделе %FineBI%/logs, там сообщается об ошибке в ключевом слове:
- Не удалось создать локальный каталог в /home/ap/bin/ROOT/temp/spark
Анализ причин:
Недостаточные привилегии пользователя, запустившего проект, привели к ошибке при создании временного каталога spark
Решение:
Проверьте права на чтение/запись пользователя, вы можете использовать команду chmod -R 777, чтобы настроить права для соответствующего пути временного каталога.
4. Проблемы с установочным пакетом
4.1 Ошибки внутренней документации
Описание проблемы:
FineBI не удалось запустить, сообщение об ошибке: An internal error occurred(error code:34).

Анализ причин:
Загруженный установочный пакет неполный.
Решение:
Повторно загрузите программу установки, чтобы установить ее.
4.2 Сбой при распаковке установочного архива
Описание проблемы:
Система Windows, флешбэк после установки инсталлятора, журнал останавливается при запуске разархивировать файл:D:\app\FineBI5.1\... \assist\update\update.zip
Анализ причин:
Запуск застрял на этапе распаковки файла плагина с ключевым словом start unzip
Решение:
Вручную распакуйте zip-файл плагина и поместите его в папку plugins, чтобы успешно запустить его
5. Ошибки при запуске проекта
Если проект запускается с ошибками или не работает, необходимо поочередно проверить следующие проблемы процесса.
5.1 FineBI многократно запускает два потока
1) Введите команду ps -ef|grep java, чтобы посмотреть, сколько потоков было запущено BI по текущему пути, как показано ниже:

2) Если существует более одного потока, то все они будут завершены, введите kill -9 номер процесса, как показано ниже:

5.2 Занятый порт FineBI
Описание проблемы:
Развертывание flashback/front-end недоступно, ключевое слово Address уже используется в журналах
Анализ причин:
Номер порта может быть занят только одним процессом. Порт, необходимый для запуска FineBI, в настоящее время занят другим процессом.
Решение:
1) Используйте команду lsof -i:port-number, чтобы проверить, занят ли текущий порт или нет. Если это показано на следующем рисунке, то порт не занят:

Примечание: Если вы получаете ошибку-bash: lsof-i:xx: команда не найдена, вам нужно ввести команду yum install lsof, чтобы использовать команду lsof.
Как показано на следующем рисунке, java-приложение с идентификатором процесса 8152 занимает порт 80:

2) Номер порта может быть занят только одним процессом. Если текущий номер порта уже занят, необходимо изменить номер порта BI-сервера на незанятый.
Для получения дополнительной информации смотрите: Конфигурация порта Tomcat, Как изменить номер порта FineBI.
5.3 Несколько проектов/отсутствие проектов в каталоге webapps
Перейдите в каталог установки BI и проверьте, есть ли несколько файлов webroot или нет файлов в каталоге %FineBI%\webapps.
Если нет, то вам нужно поместить установленный файл webroot в раздел webapps, как показано ниже:
Примечание: Файлы резервных копий хранятся в сжатых папках или копируются в каталог, который не является каталогом проекта, что гарантирует, что в веб-контейнере есть только один проект с именем webroot.

5.4 Ошибка в файле db.lck
Windows Открытая база данных FineDB с помощью других инструментов и не закрыта, проверьте, подключается ли другое программное обеспечение к встроенной базе данных FineDB, если да, то необходимо закрыть проект и перезапустить BI.
6. Проблема с именем хоста
6.1 Исключение UnknownHostException
Описание проблемы:
Запуск FineBI не удается, интерфейс сообщает об ошибке 61300110Spider Compute Engine Service Initialisation Exception
Проверяем журнал %FineBI%/logs, ошибка - UnknownHostException.
Решение:
Войдите на сервер установки, проверьте файл hosts (/etc/hosts для Linux, обычно на диске C для Windows) и добавьте IP этого сервера и соответствующее имя хоста.
6.2 Невозможность получить имя хоста
Описание проблемы:
FineBI-доступ не удается, фронт-энд выдает сообщение "Не удалось получить имя хоста, пожалуйста, проверьте, нормально ли имя хоста сервера, или перенастройте имя хоста".

Анализ причин:
Сопоставление не настроено должным образом в файле hosts сервера.
Решение:
Основываясь на значении, возвращаемом командой hostname, настройте конкретное имя хоста 127.0.0.1 в файле /etc/hosts
7. Другие вопросы
7.1 После установки FineBI не настроен интерфейс имени пользователя и пароля администратора?
Для устранения этой проблемы необходимо проверить, не был ли FineBI установлен ранее, в данном случае он был переустановлен по пути предыдущей установки.
Если вы уже устанавливали эту программу, то перед повторной установкой необходимо полностью удалить ранее установленную версию.
7.2 Исключения из файла tools.jar
Описание проблемы:
В среде Mac при развертывании FineBI на tomcat стартовый проект выдает ошибку "tools.jar exception".

Анализ причин:
При развертывании tomcat используемый tools.jar должен соответствовать jdk, настроенному в переменных окружения.
Решение:
1) Установите правильный путь к среде JAVA.
2) Замените файл tools.jar.