Оформление
Сертификация публичных облаков - Справочная документация FineReport|Разработка отчетов|Использование отчетов|Учебные пособия
Сертификация публичных облаков
1. Обзор
1.1 Версия
| Версия сервера FineBI | Функциональные изменения |
|---|---|
| 6.0 | - |
1.2 Сценарии применения
Пользователям необходимо регистрировать несколько проектов, очень хлопотно экспортировать информацию о проекте много раз, и они не хотят устанавливать локальный сервер авторизации.
Fansoft создает публичный облачный сервер аутентификации. Клиенты инициируют запросы на авторизацию, заполняя аутентификационную информацию, которая отправляется на публичный облачный сервер аутентификации для единой проверки авторизации.
1.3 Функциональный профиль
Метод регистрации в публичном облаке имеет несколько особенностей:
(1) Регистрация BI-проектов в публичном облаке не будет ограничена физической информацией, а изменения в физической информации не приведут к отказу в регистрации.
(2) Сервер BI клиента должен быть подключен к авторизованному серверу через публичную сеть. Клиенты, которым не разрешено открывать экстранет, не могут использовать этот метод регистрации.
Адреса экстранета, которые должны быть открыты, включают:
| доменное имя | порты | инструкции |
|---|---|---|
| https://register.fanruan.com | 443 | Сервер аутентификации в публичном облаке |
| https://cloud.fanruan.com | 443 | Центр управления веб-сайтами |
(3) Метод регистрации прост и удобен в эксплуатации, поэтому сбоев в регистрации практически не бывает.
(4) Пользователи, подающие заявку на одно разрешение, могут зарегистрировать несколько проектов, и цена колеблется в зависимости от "Максимального регистрируемого объема".
Его можно зарегистрировать на любом BI-сервере, что является более гибким решением.
2. Этапы регистрации
2.1 Получение информации о версии
Администратор входит в систему FineBI и нажимает "System Management > Управление регистрацией > Информация о версии", чтобы просмотреть информацию о версии.
Сохраните полный скриншот этой страницы, который вам понадобится при получении разрешения ниже.

2.2 Получение разрешения
Поддерживаются два метода приобретения:
(1) Самостоятельная регистрация (рекомендуется): с помощью онлайн-платформы для самостоятельной регистрации, без необходимости ожидания, автоматически и мгновенно генерирует файл авторизации для использования, но не поддерживает интегрированную инженерию FineReport & FineBI.
2) Помощь бизнесу: отправьте письмо в Fansoft Business, чтобы помочь в создании файла авторизации, поддержать любой проект Fansoft, но нужно терпеливо ждать.
2.2.1 Самостоятельная регистрация (рекомендуется)
Дополнительную информацию см. в разделе: Доступ к регистрационным документам в режиме Self-service
1) Пожалуйста, свяжитесь с отделом продаж Sailsoft заранее для подтверждения соответствующих вопросов и подписания контракта, а также для достижения требований по окупаемости.
(2) Пожалуйста, используйте указанную учетную запись для входа в Sailsoft Pass и завершения аутентификации на предприятии.
(3) Выберите соответствующий договор на странице "Платформа обслуживания - Регистрация продукта", подтвердите пункт функции регистрации, проведите саморегистрацию, получите учетную запись и пароль для публичного облака.
| уточнение | |
|---|---|
| 0 Подготовительные шаги | Выполните условие саморегистрации:1) Пожалуйста, свяжитесь с отделом продаж компании Sailsoft заранее, чтобы подтвердить все необходимые вопросы и подписать договор.2) Пожалуйста, обеспечьте выполнение требований по окупаемости в соответствии с договором3) Для входа в систему Sailsoft Pass используйте учетную запись, указанную в договоре.4) Пожалуйста, заполните сертификат предприятия |
| 1 Портал саморегистрации | Посетите страницу регистрации продукта |
| 2 Выбор контрактов | Выберите контракт и нажмите "Зарегистрироваться сейчасЕсли количество регистраций достигло общего числа, онлайн-регистрация будет невозможна![]() |
| 3 Подтверждение функциональной точки | Убедитесь, что лицензированные функции соответствуют функциям, указанным в контракте на продукт Sailsoft.![]() |
| 4 Выполните саморегистрацию | 1) Выберите метод регистрации: регистрация в публичном облаке2) Выберите версию модуля BI: 5.1.18 и ниже/5.1.19 и выше6.0 и ниже/6.0 и вышеПожалуйста, выберите версию в соответствии с информацией о версии в разделе 2.1. Неправильный выбор сделает файл лицензии непригодным для использования, поэтому выбирайте внимательно.3) Введите название проектаЧтобы облегчить запрос и поддержание авторизации вашей компании при возникновении проблем, пожалуйста, укажите название проекта, например: XX компания XX проект, XX регион XX проект4) Задайте учетную запись для входа в систему:Пожалуйста, задайте имя учетной записи, которую вы хотите использовать, если имя учетной записи уже занято, оно не может быть использовано.Пароль автоматически генерируется Sailsoft после успешной регистрации и не может быть исправлен.(5) Ввод количества зарегистрированных проектов: то есть количество узлов кластерного проекта, автономный ввод 1, не может быть больше, чем количество оставшихся зарегистрированных проектов![]() |
| 5 Завершение регистрации | Нажмите "Зарегистрироваться сейчас", чтобы получить учетную запись и пароль для публичного облака, и нажмите на кнопку поддержки для копирования.![]() |
2.2.2 Помощь бизнесу
Пожалуйста, отправьте регистрационную информацию на FineBI 商务business@fanruan.com, используя адрес электронной почты, указанный в вашем договоре, в следующем формате:
Бизнес получает письмо и, убедившись в его правильности, генерирует для пользователя номер учетной записи и пароль, которые отправляются ему по электронной почте.
Примечание: Если у вас есть какие-то особые обстоятельства, пожалуйста, укажите их в своем письме.
| список предметов | запрос | предостережение | |
|---|---|---|---|
| Приоритетный контакт | Пожалуйста, свяжитесь с отделом продаж Sailsoft заранее, чтобы уточнить все необходимые вопросы и подписать договор. | - | |
| От: (заголовок сообщения) | Пожалуйста, используйте адрес электронной почты, указанный в договоре | Если регистрационная информация отправлена на адрес электронной почты, отличный от указанного в договоре, она не будет зарегистрирована. | |
| Кому: (заголовок сообщения электронной почты) | business@fanruan.com | - | |
| Надпись | XXX Регистрация компании FineBI Официальный разрешительный документ | Если регистрационная информация будет отправлена без названия компании, она не будет зарегистрирована. | |
| основной текст (в отличие от сносок) | Основная информация | Название компании: XXX CompanyНазвание проекта: Проект XXXДата подписания контракта: XXXX, XX/XX/XXXX | - |
| Метод регистрации | Сертификация публичных облаков | - | |
| Максимальное количество регистраций | Количество работ, разрешенных к регистрации | Если этот параметр не указан, по умолчанию используется значение 1 | |
| имя пользователя | Имя учетной записи публичного облака | Если вам необходимо указать имя учетной записи публичного облака, укажите это в письме, если имя учетной записи уже занято, оно не может быть использовано.Если вы не укажете/назначите имя недоступной учетной записи публичного облака, Commerce сгенерирует для вас случайную учетную запись. | |
| вложение (электронная почта) | Снимок экрана с информацией о версии, полученной в разделе 2.1. | - |
2.3 Проверка регистрации
Администратор входит в систему FineBI и нажимает кнопку "System Management > Управление регистрацией > Зарегистрироваться сейчас", как показано на рисунке ниже:

Выберите метод аутентификации "Аутентификация в публичном облаке", введите номер учетной записи и пароль из письма, отправленного компанией, и нажмите "Отправить аутентификацию".

После успешной аутентификации эффект будет показан ниже:
Примечание: По умолчанию проект FineBI использует RSA для шифрования и хранения паролей в публичном облаке, если вы переключите алгоритм шифрования, то пароли будут обновляться синхронно.

3. Сбой регистрации
3.1 Описание явления
Если регистрация не удалась, на странице появится всплывающее окно, как показано ниже:

3.2 Причины неудач
Щелкните Подробнее, чтобы узнать, почему регистрация не удалась, и устранить неполадки, исходя из конкретной причины неудачи.
| код ошибки | имя ошибки | скрытый смысл |
|---|---|---|
| 10000 | JSON_PARSER_ERROR | Неправильный формат данных |
| 10001 | PARAM_INPUT_ERROR | Вы ввели неправильный параметр |
| 20000 | ДЕЛАТЬ_НЕ_НУЖНО_ДЕАКТИВИРОВАТЬ | Эта машина неавторизована, и ее не нужно отвязывать (эта подсказка появляется при отвязке, указывая, что эту машину не нужно отвязывать, поскольку она неавторизована) |
| 20001 | MYSQL_UPDATE_ERROR | Ошибка обновления базы данных MYSQL |
| 20002 | REDIS_UPDATE_ERROR | Ошибка при вставке данных в базу данных REDIS |
| 30000 | ЛИЦЕНЗИЯ_ИСТЕКЛА | Срок действия сертификата истек |
| 30001 | ОТЧЕТ_О_ВЕРСИИ_ОШИБКИ | несоответствие версий |
| 30002 | ОШИБКА_СТАТУСА_АККАУНТА | Состояние счета не соответствует норме |
| 30003 | ЛИЦЕНЗИЯ_IP_ERROR | IP не разрешен |
| 30004 | ОШИБКА_ДОМЕНА_ЛИЦЕНЗИИ | Доменные имена не разрешены |
| 30005 | ИМЯ_ЛИЦЕНЗИИ_ОШИБКА | Имена приложений не допускаются |
| 30006 | ОШИБКА_ВВОДА_СЧЕТА | Эта учетная запись и пароль не авторизованы |
| 30007 | REGISTER_OUT_OF_LIMIT | Максимальное количество разрешений достигнуто |
Примечание: Помимо вышеперечисленных причин отказа, сообщается о других унифицированных ошибках: неправильное содержание сертификата.
Если причин неудачи несколько, все они отображаются в платформе.
4. Регистрационная миграция
При отправке деловых писем указывается максимальное количество доступных регистраций.

(1) Если количество серверов не превышает максимальное количество регистрируемых серверов, вы можете напрямую использовать учетную запись публичного облака исходного сервера для регистрации на новом сервере.
(2) Если количество регистраций превышает максимальное количество регистраций, после отвязки исходного сервера новый сервер регистрируется с использованием учетной записи публичного облака исходного сервера.
Администратор входит в систему Data Decision System, нажимает "Management System > Registration Management > Version Information" и нажимает "Re-registration > Unbinding", чтобы отвязать старый сервер.
Примечание: Если исходный сервер не развязан, то когда новый сервер использует для регистрации учетную запись исходного сервера в публичном облаке, регистрация завершится неудачей с сообщением: "Достигнуто максимальное количество авторизаций".




