Оформление
Сертификация частных облаков Container - FineReport Справочная документация|Разработка отчетов|Использование отчетов|Учебные пособия
Сертификация частного облака Container
1. Обзор
1.1 Версия
| Версия сервера FineBI |
|---|
| 6.0.5 |
1.2 Сценарии применения
Проект развернут в контейнере docker, и его нельзя привязать к коду машины/MAC-адресу, поэтому аутентификация по информации о локальной машине/аутентификация в частном облаке не может быть использована.
FineBI Engineering не может подключиться к экстрасети и поэтому не может использовать аутентификацию в публичном облаке.
Пользователям требуется один сервер авторизации для авторизации нескольких серверов отчетов, поэтому они не могут использовать локальную аутентификацию контейнеров.
1.3 Функциональный профиль
FineBI предоставляет программу "Аутентификация в частном облаке Container". Пользователям необходимо подготовить два сервера.
1) Сервер авторизации: контейнерная среда docker для загрузки файлов образов стартового частного облака.
2) Сервер проекта: сервер, на котором расположен проект FineBI.
1.4 условия
(1) Сервер проекта, т.е. сервер, на котором находится зарегистрированный проект FineBI, должен взаимодействовать с сетью авторизованных серверов.
2) Сервер авторизации не должен быть выключен , и после перезагрузки потребуется повторная аутентификация.
При повторной аутентификации нет необходимости заново загружать файл изображения, просто отсканируйте QR-код еще раз, чтобы ввести проверочный код.
2. Этапы регистрации
2.1 Получение информации о версии
Администратор входит в систему FineBI и нажимает на "System Management > Управление регистрацией > Информация о версии", чтобы получить полный снимок экрана модуля "Информация о версии", как показано ниже:

2.2 Получение разрешительных документов
Пожалуйста, отправьте регистрационную информацию на FineBI 商务business@fanruan.com, используя адрес электронной почты, указанный в вашем договоре, в следующем формате:
Бизнес получает письмо, генерирует файл образа fanruan_license_server.tar сервера аутентификации для пользователя, проверяет его правильность и отправляет пользователю по электронной почте.
Примечание: Если у вас есть какие-то особые обстоятельства, пожалуйста, укажите их в своем письме.
| список предметов | запрос | предостережение | |
|---|---|---|---|
| Приоритетный контакт | Пожалуйста, свяжитесь с отделом продаж Sailsoft заранее, чтобы уточнить все необходимые вопросы и подписать договор. | - | |
| От: (заголовок сообщения) | Пожалуйста, используйте адрес электронной почты, указанный в договоре | Если регистрационная информация отправлена на адрес электронной почты, отличный от указанного в договоре, она не будет зарегистрирована. | |
| Кому: (заголовок сообщения электронной почты) | business@fanruan.com | - | |
| Надпись | XXX Регистрация компании FineBI Официальный разрешительный документ | Если регистрационная информация будет отправлена без названия компании, она не будет зарегистрирована. | |
| основной текст (в отличие от сносок) | Основная информация | Название компании: XXX CompanyНазвание проекта: Проект XXXДата подписания контракта: XXXX, XX/XX/XXXX | - |
| Метод регистрации | Сертификация частного облака Container | - | |
| Максимальное количество регистраций | Количество инженерных узлов кластера | Если этот параметр не указан, по умолчанию используется значение 1Не требуется в отдельных случаях | |
| вложение (электронная почта) | Снимок экрана с информацией о версии, полученной в разделе 2.1. | - |
2.3 Запуск сервера авторизации
1) Загрузите файл образа fanruan_license_server.tar
docker load < fanruan_license_server.tar

2) Просмотр импортированного файла изображения
По умолчанию будет два вида пакетов файлов, arm64 и amd64, пользователи могут выбрать тот, который им подходит. Ниже показан пакет amd64.
образы докеров

3) Создание контейнеров с помощью образа docker с отображением директорий
Например, отобразите /app/config на D:\William\lic\config.
docker run -v /D/William/lic/config:/app/config -P -d fanruan_license_server_amd64:1.0.0

Примечание 1: Имя каталога отображения не должно содержать пробелов, китайских иероглифов, специальных символов и т.д., иначе это может привести к ошибкам.
Примечание 2: При запуске образа по умолчанию используется сертификат https, поставляемый с контейнером, и поддерживаются только адреса localhost/127.0.0.1.
Для поддержки других IP и доменов вы можете начать отображать каталог, в котором находится сертификат, и использовать свой собственный файл сертификата.
Примечание 3: При использовании -P Docker будет случайным образом искать незанятый порт для привязки к контейнеру в диапазоне от 49153 до 65535, который является портом 49155 на хосте ниже.
Чтобы указать порт хоста, параметр -P в команде запуска можно изменить на -p порт хоста:порт контейнера
Примечание 4: Описания каталогов контейнеров приведены в таблице ниже. Если вам нужно отобразить несколько каталогов, то между каждым каталогом нужно вставить -v.
Например, сопоставьте /app/config с D:\William\lic\config, /app/log с D:\William\lic\log.
Команда: docker run -v /D/William/lic/config:/app/config -v /D/William/lic/log:/ app/log -P -d fanruan_license_server_amd64:1.0.0
| каталог (на жестком диске компьютера) | инструкции | Требуется ли отображение |
|---|---|---|
| /app/config | Создайте каталог с файлами privataConfig | Должно быть нанесено на картуДолжно быть отображено, чтобы предотвратить появление сообщений об ошибках во вторичных контейнерах запуска. |
| /app/log | Каталог журналов | Сопоставление необязательноСопоставление каталогов для облегчения доступа к журналам |
| /app/tls | Встроенный https-сертификат контейнера по умолчанию | Сопоставление необязательноЕсли его не назначить, аутентификация в частном облаке по умолчанию будет поддерживать только соединения с IP localhost или 127.0.0.1.Если сопоставление необходимо, вы должны сами поместить файл сертификата в этот каталог, иначе сервер аутентификации не сможет запуститься. |
| /app/web | Внешние файлы QR-кодов | неприсоединяемыйСопоставление приводит к недоступности страницы сканирования |
4) Список информации о запущенном контейнере
docker ps

2.4 Представление сертификата
Как видно из приведенного выше раздела, порт 8081 контейнера docker сопоставлен с портом 49155 хоста.
Посетите сайт https://172.16.63.131:49155/license/qrcode即可进行扫码认证. (IP и порт должны быть скорректированы в соответствии с вашей реальной ситуацией)
Отсканируйте сгенерированный QR-код с помощью мобильного браузера/WeChat, на экране появится 6-значный проверочный код, введите его в систему и нажмите "Submit Authentication". Как показано на рисунке ниже:
Примечание 1: QR-код действителен в течение 5 минут, пожалуйста, завершите процесс регистрации в течение указанного времени. Через 5 минут QR-код покажет, что его необходимо обновить вручную.
Примечание 2: После того как код сканирования мобильного телефона вернет проверочный код, проект лучше зарегистрировать сразу, не перезапускайте проект до успешной регистрации.
Примечание 3: Для предотвращения взлома CAPTCHA методом грубой силы и высокочастотного доступа к интерфейсу, если количество ошибок ввода CAPTCHA превысит 5, он будет заблокирован на 15 минут.

2.4 Авторизация аутентификации сервера FineBI
Администратор входит в систему FineBI и нажимает "System Management > Управление регистрацией > Зарегистрироваться сейчас", как показано ниже:

Выберите "Private Cloud Authentication" для метода аутентификации, введите IP и порт прослушивания авторизованного сервера, например, https://172.16.63.131:49155, и нажмите "Submit Authentication", как показано на следующем рисунке:
Примечание: Убедитесь, что сервер FineBI имеет доступ к серверу авторизации.

После успешной аутентификации, как показано на следующем рисунке:

Примечание 1: Максимальное количество соединений здесь указывает на то, сколько проектов могут одновременно подать заявку на регистрацию авторизации на сервере авторизации.
Примечание 2: Если аутентификация не проходит, проверьте настройки брандмауэра и откройте соответствующий порт или закройте брандмауэр.
3. Сбой регистрации
3.1 Описание явления
Если регистрация не удалась, на странице появится всплывающее окно, как показано ниже:

3.2 Причины неудач
Щелкните Подробнее, чтобы узнать, почему регистрация не удалась, и устранить неполадки, исходя из конкретной причины неудачи.
| код ошибки | имя ошибки | скрытый смысл |
|---|---|---|
| 10000 | JSON_PARSER_ERROR | Неправильный формат данных |
| 10001 | PARAM_INPUT_ERROR | Вы ввели неправильный параметр |
| 20000 | ДЕЛАТЬ_НЕ_НУЖНО_ДЕАКТИВИРОВАТЬ | Машина неавторизованная и не нуждается в откреплении |
| 30000 | ЛИЦЕНЗИЯ_ИСТЕКЛА | Срок действия сертификата истек |
| 30001 | REPORT_VERSION_ERROR | несоответствие версий |
| 30002 | ОШИБКА_СТАТУСА_АККАУНТА | Статус учетной записи не в норме (это сообщение появляется при отвязке, указывая, что эту машину не нужно отвязывать, поскольку она не авторизована) |
| 30003 | ЛИЦЕНЗИЯ_IP_ERROR | IP не разрешен |
| 30004 | ОШИБКА_ДОМЕНА_ЛИЦЕНЗИИ | Доменные имена не разрешены |
| 30005 | ИМЯ_ЛИЦЕНЗИИ_ОШИБКА | Имена приложений не допускаются |
| 30007 | REGISTER_OUT_OF_LIMIT | Максимальное количество разрешений достигнуто |
4. Сертификационная миграция
Если вам нужно перенести авторизованный сервер для проекта, прошедшего сертификацию Container Private Cloud, выполните следующие действия.
4.1 Уничтожение разрешения на создание оригинальных произведений
Пожалуйста, отправьте письмо в FineReport 商务business@fanruan.com, используя адрес электронной почты, указанный в вашем договоре.
Пожалуйста, четко опишите адрес сервера авторизации, который необходимо перенести, в теле письма, например, https://172.16.63.131:49155 в разделе 2.4.
Компания получает электронное письмо и, убедившись в его правильности, уничтожает соответствующую авторизацию пользователя и уведомляет его об этом по электронной почте.
Примечание: Не перезагружайте авторизованные серверы, подлежащие миграции, до получения четкого ответа от Commerce.
4.2 Скопируйте файл privateConfig.
1) Выключите сервер авторизации, который необходимо перенести.
2) Получите автоматически сгенерированный файл privateConfig по пути /app/config контейнера.
4.3 Получение нового разрешительного документа
Пожалуйста, отправьте письмо в FineReport 商务business@fanruan.com, используя адрес электронной почты, указанный в вашем договоре.
Обратитесь к разделу 2.1 этого документа, чтобы узнать формат письма, и дополнительно прикрепите файл privateConfig, полученный на предыдущем шаге.
Бизнес получает письмо, генерирует файл образа fanruan_license_server.tar сервера аутентификации для пользователя, проверяет его правильность и отправляет пользователю по электронной почте.
Затем пользователи могут выполнить действия, описанные в главе 2, чтобы запустить новый сервер авторизации для регистрации.