Skip to content

Развертывание Websphere и использование общих отчетов об ошибках

1. Обзор

В этой статье описываются проблемы и решения, возникающие после развертывания FineBI на WebSphere.

2. Примеры

2.1 Сообщение об ошибках 404

проблемное явление

WebSphere развернула и ввела адрес доступа, сообщив об ошибке Error 404: java.io.FileNotFoundException: SRVE0190E: File not found: /decision, как показано ниже:

1.png

Анализ причин

Проверьте, установлена ли ОС (AIX) на клиенте WebSphere, и не противоречит ли языковая среда, соответствующая ОС (AIX) WebSphere, использованию FineBI.

Рецепт

Например, для просмотра языковой среды ОС WebSphere (AIX) по умолчанию используется следующее значение:

  
  
  
  
  
LANG=C LC_COLLATE="C" LC_CTYPE="C" LC_MONETARY="C" LC_NUMERIC="C" LC_TIME="C" LC  
_MESSAGES="C" LC_ALL=

Локаль C не соответствует значению по умолчанию в FineBI, необходимо изменить ее на en_US.UTF-8 и перезапустить сервер WebSphere.

2.2 ERRORCODE=-4220, SQLSTATE=22021

проблемное явление

FineBI, установленный напрямую, может подключаться к базе данных IBM DB2, но после упаковки и развертывания на WebSphere он не может подключиться к базе данных DB2 и сообщает об ошибке: ERRORCODE=-4220, SQLSTATE=22021, как показано на следующем рисунке:

1.png

1.png

Анализ причин

Когда приложение использует драйвер IBM Data Server Driver for JDBC and SQLJ (также известный как драйвер JCC) и подключается к базе данных, используя набор кодов UTF-8 (кодовая страница 1208), оно выбрасывает SqlException, содержащий сообщение "Capturing java.io. io" сообщение. CharConversionException" и ERRORCODE=-4220, если данные в запрашиваемом символьном столбце содержат последовательность байтов, не являющуюся правильной строкой UTF-8.

Рецепт

"Перейдите в Server > WebSphere application Servers > server_name > Java and Process Management > Process Definition > Java Virtual Machine, установите флажок "Debugging Method" и добавьте параметр в General JVM Parameters: -Ddb2.jcc. charsetDecoderEncoder = 3, как показано ниже:

1.png

После успешного добавления перезапустите WebSphere и снова подключитесь к базе данных IBM DB2.

2.3 Не настроен целевой сервлет для uri:/webroot/decision

проблемное явление

После успешного развертывания проекта FineBI WebSphere сообщает об ошибке 404: com. ibm. ws. webcontainer. servlet. exception. noTargetForURLE. "решение"), страница сообщает об ошибке 404: com. ibm. ws. webcontainer. servlet. exception. NoTargetForURLException: No targetсервлета, сконфигурированного для uri: /webroot/decision, как показано ниже:

1.png

Анализ причин

При развертывании в соответствии с развертыванием сервера Linux Websphere при сопоставлении контекстного корня для веб-модуля и изменении контекстного корня на имя проекта вы можете указать имя проекта, отличное от webroot, и тогда при вводе адреса доступа и использовании имени файла проекта webroot для доступа к нему вы получите ошибку NO target servlet configgred для uri:/webroot/decision, как показано ниже:

1.png

Рецепт

Определите контекстный корень, введенный на шаге 7: Сопоставление контекстных корней для веб-модулей. Например, если для контекстного корня введен адрес /home/wasadmin, после успешного развертывания вам нужно использовать: http: //ip:port/home/wasadmin/decision для адреса доступа, как показано на следующем рисунке:

1.png

2.4 Конфигурация привилегий Невозможно выбрать таблицу данных полей для вошедших пользователей, содержащих китайские символы

проблемное явление

Можно выбрать только имя пользователя системы, но нельзя выбрать таблицу данных "Поле пользователя для входа", содержащую китайские символы.

Анализ причин

Проблемы кодирования сервера WebSphere.

Рецепт

Измените кодировку WebSphere на UTF-8.

1) Перейдите в раздел "Server>Server Type>WebSphere Application Server>SuiteServer>Process Definition>Java Virtual Machine".

Измените общие параметры JVM на -Dfile.encoding=UTF-8 -Ddefault.client.encoding=UTF-8, как показано ниже:

12.png

2) Перейдите в каталог %IBM%WebSphere/AppServer/profiles/AppSrv01/config/cells/10Cell01/nodes/10Node01/servers/SuiteServer

Измените параметр genericJvmArguments="-Dfile.encoding=UTF-8 -Ddefault.client.encoding=UTF-8" в файле server.xml.

2.5 Невозможность отправки почты

Описание проблемы

FineBI развернут в WebSphere,выбран любой BI-шаблон, выполнено задание планирования по времени, но не удается получить сообщение электронной почты, и появляется сообщение о том, что доставка электронной почты не удалась. Как показано на следующем рисунке:

javax.net.ssl.SSLException: Connection has been shutdown: javax.net.ssl.SSLHandshakeException: com. ibm.jsse2.util.h: Не удалось построить путь PKIX: java.security.cert.CertPathBuilderException.   
PKIXCertPathBuilderImpl не смог построить действительный CertPath.; внутренняя причина: java. security.cert.CertPathValidatorException: The certificate issued by CN=DigiCert Global Root&... nbsp;CA, OU=www.digicert.com, O=DigiCert Inc, C=US не является доверенным; внутренняя причина&#8482  
nbsp;это: java.security.cert.CertPathValidatorException: Ошибка цепочки сертификатов

Критическая ошибка отчетности:

Сертификат, выданный CN=DigiCert Global Root CA, OU=www.digicert.com, O=DigiCert Inc, C=US, не является доверенным;

Анализ причин

Доверие к сертификатам Digicert CA не добавляется в средах WebSphere.

Рецепт

Загрузите сертификат Digicert CA из браузера IE, затем добавьте сертификат в среду WebSphere и перезапустите WebSphere .

1) Откройте "Internet Explorer>Настройки>Параметры Интернета>Содержимое>Сертификаты>Доверенные корневые центры сертификации>DigiCert Global Root CA", эмитентом также является сертификат DigiCert Global Root CA, экспортируйте сертификат и выберитедвоичный формат с кодировкой DER. Экспортируйте сертификат и выберите двоичный формат в кодировке DER. Как показано на следующем рисунке:

1611910476642175.png

Загруженный файл сертификата digicert.cer:файл сертификата.zip

2)После экспорта загрузите файл в любой каталог на сервере WebSphere (для каждого узла), например в каталог/home.

3) Войдите в консоль WebSphere и выберите " Security > SSL Certificate and Key Management > Key Vaults and Certificates", как показано ниже:

1611911528314094.png

4) Нажмите на NodeDefaultTrustStore, как показано ниже:

1611911580665960.png

5) Нажмите на сертификат подписывающего лица, как показано ниже:

1611911630491430.png

6) Затем нажмите кнопку "Добавить", введите псевдоним (его можно написать произвольно), пропишите перед именем файла полный путь к загруженному на сервер файлу сертификата, например /home/digicert.cer, выберите для типа данныхдвоичные ER-данные, а затем нажмите кнопку Применить. Как показано на рисунке ниже:

1611910945201505.png

7) После завершения работы приложения нажмите Save to Configuration, затем перезапустите WebSphere , войдите в BI, а затем отправьте почту, чтобы добиться успеха!

Примечание: Другие узлы также должны развернуть этот сертификат.

1611911049936376.png