Skip to content

Введение в мастер развертывания сервера Страница

1. Обзор

1.1 Версия

Версия сервера FineBIФункциональные изменения
6.0-

1.2 Сценарии применения

При развертывании сервера по разным причинам может произойти сбой, и пользователю будет предоставлена страница, на которой он сможет обнаружить и устранить проблему.

1.3 Функциональный профиль

В случае сбоя при развертывании сервера пользователь получает инструкции, позволяющие вовремя обнаружить и устранить проблему для успешного развертывания.

2. Этапы развертывания

Этапы развертывания показаны в таблице ниже:

контейнерыинструкции
TomcatВерсия JDK: JDK 1.8 и младшая версия должны быть выше JDK8u102, подробности см. в разделе " Развертывание сервераTomcat ".
WeblogicВерсия JDK: JDK 1.8 и младшая версия должны быть выше JDK8u102, подробности смотрите в разделе: Развертывание Weblogic Server.
WildflyДополнительную информацию см. в разделах: Развертывание сервера Wildfly (JBoss) 9~18, Развертывание сервера Wildfly (JBoss) 8.
WebSphereДополнительные сведения см. в разделе: Развертывание сервера Websphere для систем Linux.
СмолаДополнительную информацию см. в разделе: Развертывание сервера Resin

3. Содержание теста мастера развертывания сервера

3.1 Аномалии среды развертывания

Сообщение об ошибке: Исключение среды развертывания

**Решение:**Дополнительные сведения см. в разделе:Аномалии среды развертывания

Страница отчета об ошибках показана ниже:

1645429432350636.png

3.2 Исключения при подключении к базе данных

3.2.1 Сбой подключения к встроенной базе данных

**Сообщение об ошибке:**исключение подключения к базе данных, не удалось установить соединение со встроенной базой данных.

Решение: Удалите файл db.lck в каталоге WEB-INF/embed/finedb.

1614568766221786.png

3.2.2 Сбой подключения к внешней базе данных

Сообщение об ошибке: исключение подключения к базе данных, внешнее подключение к базе данных не удалось.

Решение:

Пожалуйста, подтвердите информацию о подключении к базе данных, измените конфигурацию внешней базы данных, а затем нажмите кнопку "Retest", если подключение прошло успешно, новая база данных будет включена напрямую.

Обратите внимание, что в базе данных должна быть информация о таблице finedb, если информация о таблице отсутствует, то целевая база данных является новой базой данных и не может быть использована.

2.png

3.3 исключения портов websocket

Сообщение об ошибке: исключение порта websocket.

Решение: Порт websocket занят другим процессом и должен быть изменен на свободный порт.

1614568897690500.png

3.4 Внешние исключения из базы данных

**Сообщение об ошибке:**исключение из внешней базы данных , а также сообщение об ошибке:проверьте, есть ли у пользователя базы данных права на создание и изменение таблиц, или проверьте журналы базы данных, чтобы устранить неполадку.

Решение:

Сначала проверьте, нет ли у пользователя базы данных привилегий на создание и изменение таблиц, если да, то дайте ему эти привилегии.

Если нет, проверьте журналы базы данных для дальнейшего устранения проблемы.

Примечание: Внешним пользователям базы данных, не имеющим привилегий, связанных с базой данных, во время обновления будет предложено завершить обновление.

3.png

4. Примеры

Ниже приведена демонстрация на примере контейнера Tomcat. Скопируйте папку %BI_HOME%/webapps/webroot в папку %TOMCAT_HOME%/webapps и запустите Tomcat.

4.1 Переход на страницу мастера развертывания

После того как запуск проекта завершился неудачно, посетите платформу http://localhost:8080/webroot/decision, и запуск проекта webroot завершится неудачей и автоматически перейдет на страницу мастера развертывания сервера http://localhost:8080/webroot/decision/v10/. развертывания/рекомендации, как показано на следующем рисунке:

7.png

4.2 Следуйте подсказкам

Скопируйте файл tools.jar из папки %JAVA_HOME%\jdk\libв папку %Tomcat_home%\webapps\webroot\WEB-INF\lib, как показано ниже:

16.png

4.3 Успешное развертывание

Перезапустите Tomcat, в это время снова посетите платформуhttp://localhost:8080/webroot/decision, перейдите на страницу входа в систему, то есть развертывание прошло успешно. Как показано на рисунке ниже:

17.png