Skip to content

Аномалии среды развертывания

1. Обзор

При развертывании серверов могут возникать сбои в развертывании, и"Исключение среды развертывания" является одной из причин, пользователи могут проверить и устранить проблему на странице мастера развертывания.Причины "Deployment Environment Exception" делятся на различные сценарии, и в этой статье мы расскажем о конкретных ошибках и их решениях. Страница сообщения об ошибке показана на следующем рисунке:

1645429071220395.png

2. файл tools.jar не существует

Примечание 1: Здесь мы рассматриваем Tomcat в качестве примера для демонстрации, другие контейнеры также копируются в lib соответствующего контейнера.

Примечание 2: файл tools.jar в каталоге %JAVA_HOME%/jdk/lib находится в локальном JAVA_HOME сервера развертывания, а не локальной машины разработки.

Скопируйте файл tools .jar из папки %JAVA_HOME%/jdk/lib на развернутые серверы, то есть в папки %TOMCAT_HOME%/lib и %TOMCAT_HOME%/webapps/project name/WEB_INF/lib. Это показано на рисунке ниже:

1645429083523534.png

3. несоответствие инструментария.jar

Сообщение об ошибке, например, вызвано: java.lang.UnsatisfiedLinkError: sun.tools.attach.LinuxVirtualMachine.isLinuxThreads()Z

В зависимости от сообщения вы можете определить, поставила ли среда Windows файл Linux tools.jar или среда Linux файл Windows tools.jar.

4. attach.dll не существует

Присутствует ошибка в журнале: Вызвано: com.sun.tools.attach.AttachNotSupportedException: не установлены провайдеры

При установке JDK в Windows одновременно устанавливается отдельный jre. В отдельном jre нет файла attach.dll, который необходим для запуска BI.

Вам нужно скопировать attach.dll из %JAVA_HOME%/jdk/jre/binв%JRE_HOME%/bin. Как показано на рисунке ниже:

1645429205284329.png

5. /tmp не доступен для записи

Присутствует ошибка в журнале :Вызвано: com.sun.tools.attach.AttachNotSupportedException: Невозможно открыть файл сокета: целевой процесс не отвечает или HotSpot VM не загружена загружен

В каталог /tmp невозможно записать файлы, возможные причины и решения - следующие:

  • Обычные пользователи не имеют прав, используйте администратора для расширения прав /tmp chmod -R 1777 /tmp; 1 означает, что это липкий бит, его роль заключается в том, что только создатель и root могут удалять.
  • Место на диске, где находится /tmp, заполнено, просто очистите диск.

6. java.io.tmp не может быть записан в

Различные контейнеры развертываются с разными расположениями, на которые указывает java.io.tmp. Возможными причинами этого являются:

  • У пользователя нет никаких разрешений, ему достаточно полномочий.
  • Место на диске, где находится java.io.tmp, заполнено, просто очистите диск.

7. Проблемы с версией GLIBC

Решение: Обновите gcc, для получения подробной информации обратитесь к baidu.

После завершения обновления введите: ldd FineAssist_x86_64.so в командной строке, как показано ниже, это нормально.

1645429220719435.png

8. Неизвестное исключение FinePrivacy

Чтобы обратиться в службу технической поддержки с журналом загрузки, перейдите в раздел [ Платформа обслуживания > Онлайн-поддержка].

9. fontconfig отсутствует/Dec-Basic_Non_Existent

OpenJDK в пакете развертывания сервера не поставляется с пакетами шрифтов по соображениям авторского права. Если в самом Linux отсутствует пакет шрифтов, он сообщит об ошибке: fontconfig отсутствует, или Dec-Basic_Non_Existent.

Поэтому необходимо, чтобы пользователь обнаружил fontconfig, прежде чем приступать к развертыванию.

Методы обнаружения:

Пользователи могут определить, установлен ли fontconfig на сервере, выполнив команду fc-list на сервере или обнаружив существование файла fc-list в каталоге /usr/bin.

Способ установки:

Пользователи могут установить fontconfig от Baidu в соответствии со своими системными условиями.

Как правило, в Linux можно напрямую выполнить команду yum install fontconfig, успешно установить, а затем перезапустить приложение sailsoft.

10. В серверной среде отсутствуют графические библиотеки libxrender и libxtst

Решение 1: Установите headless=true (рекомендуется)

Безголовый режим - это рабочий режим системы, в котором используется безголовый инструментарий, если системное свойство java.awt.headless установлено в true.

В этом разделе описаны шаги по включению безголового режима в среде Tomcat.

  • Windows: Перейдите в каталог %Tomcat_HOME%\bin. Найдите файл с именем setenv.bat. Если файл не существует, создайте новый файл setenv.bat. Добавьте в него следующие строки для настройки и перезапустите проект после завершения настройки.

set JAVA_OPTS=%JAVA_OPTS% -Djava.awt.headless=true

  • Linux : Перейдите в каталог %Tomcat_HOME%\bin. Найдите файл с именем setenv.sh. Если он не существует, создайте новый файл setenv.sh. Добавьте в него следующие строки для настройки и перезапустите проект после завершения конфигурации.

java_opts="$JAVA_OPTS -Djava.awt.headless=true"

Решение 2: Установите недостающую графическую библиотеку

Пользователи экстранета:

Выполните командную строку для установки графической библиотеки в режиме онлайн (пример для системы unbuntu)

  • apt-get install libxrender-dev
  • apt-get install libxtst-dev

Пользователи интранета:

1) Посетите сайт https://developer.aliyun.com/packageSearch?word=libxrender и выберите пакет установки по системе и версии.
2) Установить вручную, образец заявления об установке:

  • Для систем с семейством пакетов deb (например, ubuntu): dpkg -i **.deb
  • Для систем с семейством пакетов rpm (например, centos) : yum install **.rpm

11. Библиотека времени выполнения msvcr120.dll не существует

Описание проблемы

Ошибка msvcr120.dll runtime library does not exist при установке или развертывании версии 5.1.15 и более поздних версий на системах Windows.

Рецепт

Перед развертыванием рекомендуется установить файл msvcr120.dll, см. загрузку отсутствующего файла: Microsoft Visual C++ Redistributable latest support download.

Примечание: Эту проблему можно решить, только загрузив Visual Studio 2010 (VC++ 10.0) версии SP1