Skip to content

Устранение ошибок предварительного просмотра набора данных SQL

1. Отчеты об ошибках ORA

1.1 Отчеты об ошибках

Предварительный просмотр набора данных завершается неудачно, сообщая об ошибке, начинающейся с ORA, например ORA-0911.

1.2 Анализ причин

Эта часть ошибки является ошибкой базы данных Oracle.

1.3 Решения

Эту часть ошибки можно обнаружить с помощью поиска сообщений об ошибках в Интернете.

Например, более распространенная ошибка ORA-0911 означает, что оператор SQL содержит недопустимые символы, и вам нужно проверить, содержит ли он недопустимые символы.

2. 62400001 найдены дублирующиеся имена полей

2.1 Отчеты об ошибках

Добавьте ошибку предварительного просмотра набора данных SQL: 62400001duplicate field names found: shop number, как показано ниже:

127.png

2.2 Анализ причин

В наборе данных BI имена столбцов не могут дублироваться в одной и той же таблице, иначе будет выдано сообщение об ошибке.

2.3 Решения

Проверяет дублирование имен столбцов при получении чисел из базы данных.

Если вам нужно взять два столбца с одинаковыми данными, есть два способа сделать это:

1) Переименовав дублирующиеся столбцы, например, select store_number , store_number as store_number1 from new_salesdetail. как показано ниже:

image.png

2) Скопируйте столбец с помощью функции "Новый столбец" в наборе данных Self-service, подробнее см. в разделе " Новый столбец ".

3. незаконное сочетание колаций

3.1 Отчеты об ошибках

Ошибка предварительного просмотра набора данных SQL: Неправильное сочетание колаций (utf8_unicode_ci,IMPLICIT) и (utf8_general_ci,IMPLICIT)

3.2 Анализ причин

Несоответствующая кодировка или специальные символы в операторе SQL.

3.3 Решения

Унифицируйте кодировку до "utf8_unicode_ci".

Например, если SQL-запрос выглядит так: select * from a where aa='aa', то он компилируется в "utf8_general_ci".

Чтобы изменить его на кодировку "utf8_unicode_ci", SQL-запрос выглядит так: select * from a where aa=CONVERT('aa' USING utf8) COLLATE utf8_unicode_ci

4. Добавьте ошибку сохранения набора данных SQL

4.1 Отчеты об ошибках

Подключение к базе данных SQL Server для добавления сохранения набора данных SQL не удается, как показано на следующем рисунке:

1.png

Откройте файл %FineBI%fanruan.log, в журнале сообщается об ошибке, как показано ниже:

31.png

4.2 Анализ причин

Во время выполнения транзакции в базе данных SQL Server несколько транзакций выполняются одновременно, что приводит к тупиковой ситуации, в результате чего таблица не может быть добавлена должным образом.

4.3 Решения

Обратитесь к операциям базы данных, чтобы обработать заблокированную транзакцию, или перезапустите базу данных напрямую.

Подробности перезапуска базы данных можно найти в разделе: Командная строка управления перезапуском SQL-сервера и несколько методов запуска SQL Server.